icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.dongyanzixun.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

河南彩票 www.03dc.com-学彩铅风景画图片| www.2164.vip-彩票11选五云南| www.24735.com-彩铅花卉简单| www.629718.com-足彩14場比分直播| www.744287.com-登录凤翔彩票| www.006784.com-七星彩哪个台直播| www.112903.com-分分彩跨度的规律| www.233724.com-e球彩技巧-| www.ho00.com-中彩在线是骗局吗| www.005553.com-大发快三全民彩票| www.111164.com-河北快三购买平台| www.203281.com-江苏e球彩开奖直播| www.81pl.com-赣州福利彩票店店址| www.4777.net-美国一分彩是假的吧| www.288994.com-全民彩票下载安装| www.088691.com-福利彩票网站靠谱吗| www.tf57.com-大发快三预测团队| www.555146.com-全民彩票苹果版下载| www.812922.com-手机彩膜怎么贴视频| www.912101.com-彩计划gcbcc| www.e20.tv-乐和彩票app下载| www.7290.pw-彩虹频道直播源分享| www.52955.cc-篮球胜负竞彩玩法| www.883817.com-博彩彩票站-| www.970610.com-今天福彩3b式机号| www.cp437.com-甘肃快三一定牛荐号| www.fg43.com-快三中奖概率最高| www.14lr.com-新浪彩七星彩走势图| www.6139.cm-神圣彩票平台怎么样| www.86833.cc-竞彩猫合买微信群| www.132973.com-澳门世界杯足彩盘口| www.4811.cn-彩虹六号台词| www.008815.com-彩票大数据-| www.sy96.com-来一组彩票号| www.41qe.com-七星彩加注什么意思| www.83bv.com-彩印包月-| www.549058.com-今晚天彩票几点开奖| www.729.club-时时彩个位5码技巧| www.38217.com-八亿彩安卓下载| www.265031.com-快三网上有人带着买| www.91390.com-泰国好彩双爆| www.156450.com-好彩堂一肖两码| www.316397.com-大通彩票-| www.130980.com-结婚彩礼价目表| www.237469.com-昨天福彩开奖号码| www.153366.com-湖北福彩有几种玩法| www.271194.com-好彩双爆-| www.247472.com-福彩了d开奖| www.358756.com-海南七星彩网址| www.447880.com-3d说彩视频-| www.01680.com-福利彩抢红包| www.70114.com-幸运彩票提款提不了| www.9997.bid-567彩票主播| www.69524.com-彩99老版-| www.535932.com-很好的彩票选择号码| www.5599.date-江苏快三中大奖| www.28049.com-xy1688彩票-| www.801978.com-吉林省福彩中心秦岭| www.913252.com-彩客站主页-| www.977322.com-彩礼不得超2万| www.aa07.cc-福建快三走势图和值| www.yd12.com-福彩快三推荐号码| www.19ei.com-汇金彩票-| www.1011.vip-福彩快开多期| www.im3.com-vip彩票网-| www.e08.net-竞彩神单-| www.33dd.com-幸运飞艇彩票软件| www.464787.com-七星彩领奖日期| www.558268.com-幼儿彩铅画图片大全| www.660025.com-吉林彩票快三39期| www.727719.com-福彩中奖号查询| www.795862.com-福彩怎样选号| www.867222.com-v8彩票下载-| www.929672.com-七星彩简单公式| www.978961.com-体彩大乐透网上投注| www.98cl.com-福彩字迷-| www.5529.me-福利彩票站点缴费| www.3025.top-金宝彩网站-| www.10026.com-齐鲁风采七乐彩今晚| www.127903.com-彩虹歌曲-| www.229177.com-南粤好彩三开奖| www.315606.com-何振东竞彩-| www.47nz.com-体彩六十一走势| www.1274.cc-福彩快乐三怎么玩| www.7746.com-体彩毒胆三天计划| www.134845.com-江苏体彩超级大乐透| www.235266.com-广西快三到几点结束| www.518230.com-猜动物彩票开奖| www.610069.com-7星彩l-| www.eq67.com-新华彩票-| www.uh59.com-福利彩票是真的| www.35al.com-海南七星彩日日升图| www.209.biz-水溶彩铅的画| www.027117.com-广西快三计划app| www.108695.com-下载全部彩票软件| www.764606.com-玩彩网苹果版下载| www.843514.com-中国体育彩票活动| www.906614.com-我要买彩票双色球| www.965498.com-百盈时时彩计划全天| 凤凰彩票www.77802h.com| www.019439.com-贵阳体育彩票| www.152586.com-uu快三代理-| www.256777.com-旺彩社区下载| www.113703.com-三彩家-| www.713843.com-福彩3的图谜总汇| www.790092.com-炫彩意思-| www.860205.com-甘肃快三专家追号| www.921167.com-神彩彩票是真的吗| www.975305.com-休闲快三套路| 天天中彩票www.836595.com| www.lk26.com-兴盈快三犯法吗| www.533664.com-云南省第三届彩云杯| www.611240.com-江苏快三出号分析| www.692368.com-中国合买彩票下载| www.763692.com-足彩推单app| www.871762.com-福彩刮刮乐中奖图片| www.931185.com-玩彩票被骗怎么追回| www.979154.com-内蒙快三怎么猜号码| 好彩头www.000128a.com| www.lt97.com-中彩网正版-| www.665712.com-七色彩虹鸡尾酒图片| www.022134.com-020彩票网-| www.104035.com-竞彩奖金怎么计算| www.179168.com-安微福利彩票| www.hd99.cc-3d彩民预测-| www.927363.com-体彩共选几个号| 聚彩网www.290282.com| www.lj91.com-谁开发的豪彩vip| www.k42.cc-今天3d彩民乐图| www.45ee.com-彩虹3无人机造价| www.618088.com-彩票真的中不了| www.691093.com-任九胜负彩开奖结果| www.119403.com-江苏快三兑奖范围| www.900438.com-河十一选五爱彩乐| www.964802.com-体彩大乐透预测杀号| 凤凰彩票www.55228j.com| www.ic49.com-彩名堂免费计划官网| www.638075.com-竞彩店合伙人| www.790097.com-体育彩票选号分布| www.905911.com-甘肃体彩app下载| www.985897.com-河北快三能组多少组| www.nz0.com-优乐彩平台-| www.wz94.cc-湖北快三号码分布表| www.42rp.com-原彩显示哪里设置| www.db14.com-彩票店做私庄犯法吗| www.zu84.com-ro分分彩开奖记录| www.37pj.cc-连中彩票快3| www.1102.mobi-羸彩彩票与你同行| www.150051.com-彩吧vip快三下载| www.4910.com-688彩票例行审核| www.192230.com-福利彩票快三| www.228111.cc-江苏快三有人控制吗| www.313224.com-外围彩票网站哪个好| www.397670.com-福彩开奖规则| www.321880.com-万能彩票中奖软件| www.495422.com-北京快三今天开奖号| www.606511.com-游元东路体育彩票店| www.167366.com-中国福彩快3开奖| www.987007.com-菠萝彩软件-| www.jq96.com-彩神大发快三app| www.137543.com-l中国体彩官方网站| www.999912.cc-希腊十分彩是什么彩| www.654355.com-叫彩之源的app| www.774379.com-七乐彩复式怎么玩|